Essential Grid v2.0.9 – WordPress Plugin

Essential Grid v2.0.9 – WordPress Plugin
Version 2.0.9
Compatible with WPML, WooCommerce 2.3.x, WooCommerce 2.2.x, WooCommerce 2.1.x, Bootstrap 2.0
Support WordPress 4.2, WordPress 4.1, WordPress 4.0, WordPress 3.9, WordPress 3.8, WordPress 3.7
Designers CodeCanyon
Added 30-04-2015

Essential Grid is a premium plugin for WordPress that allows you to display various content formats in a highly customizable grid. Possible applications range from portfolios, blogs, galleries, WooCommerce shops, price tables, services, product sliders, testimonials and anything else you can imagine.
Version 2.0.9 Artemis (28th April 2015)
Added compatibility with WordPress version 4.2 regarding split terms changes
Fixed a very low risk vulnerability to stay on par with security standards

View Demo Downloads