Swift Security v1.2.4 – The Ultimate WordPress Protection

Swift Security v1.2.4 – The Ultimate WordPress Protection
Version 1.2.4
Compatible with
Support WordPress 4.1, WordPress 4.0, WordPress 3.9
Layouts
Columns
Designers CodeCanyon
Added 03-03-2015

With the Swift Security plugin you can make your WordPress website more secure with a single click. A great advantage of the plugin is that you don’t need any special technical knowledge.
3 March 2015 - 1.2.4
[NEW] Automatic Troubleshooting
[NEW] Custom Logout Page
[NEW] Spanish Translation
[NEW] 3rd Party Compatibility Fixes

View Demo Downloads